Install boost via homebrew (with pythonbrew)

Below is recommended option and thanks to Sharpie to fix this.

Use:
$ brew install boost –without-python

#7633: boost install 1.47.0 failed – Issues – mxcl/homebrew – GitHub

boost with python conflicts with python2.7.1 from pythonbrew. So to use option, “–without-python”.

After install boost completed, run version check script.

https://gist.github.com/1231283

 

$ g++ this-version-check-script.cpp
$ ./a.out
Boost version: 0.198.fc

Great!

c++ – How to determine the Boost version on a system? – Stack Overflow
http://stackoverflow.com/questions/3708706/how-to-determine-the-boost-version-on-a-system

 

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中