php5.2でテスト動かすの難しくて憤死

php5.2のテストtravis-ciで動かしてphp5.2対応って気軽に言う奴らを憤死させよう!って社内LTしたらさっそく自分で憤死するはめになった
– composer requires php5.3+
– pyrus requires php5.3+
– setupでtest skipのマーク付けてもnamespace付きのコードが混じってるとphp5.2でsyntax error
そしてまだtest failじゃなくてfatalなのがきびしいがそろそろ飽きてきたのでpull requestでadviceもらうことにした
広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中