Unexpected gem dependency (at least for me)

Background knowledge

current rspec stable version: 2.14.1
next break backward compatible version beta: 3.0.0.beta1
ready for v3 version beta: 2.99.0.beta1

http://rubygems.org/gems/rspec

I have strange behavior about add_development_dependency (At least for me). Yes, I want to use pre-release version at that time, but v3.0.0 I don’t want yet…

Tachikoma’s gemspec:

spec.add_development_dependency ‘rspec’, ‘>= 2.14.0.rc’

I wrote this before release of 2.14.0.

Then:

Installing rspec-core (3.0.0.beta1)
Installing rspec-support (3.0.0.beta1)
Installing rspec-expectations (3.0.0.beta1)
Installing rspec-mocks (3.0.0.beta1)
Installing rspec (3.0.0.beta1)

I change gemspec:

spec.add_development_dependency ‘rspec’, ‘>= 2.14.0’

Then:

Installing rspec-core (2.14.7)
Installing rspec-expectations (2.14.4)
Using rspec-mocks (2.14.4)
Using rspec (2.14.1)

広告

コメントを残す

以下に詳細を記入するか、アイコンをクリックしてログインしてください。

WordPress.com ロゴ

WordPress.com アカウントを使ってコメントしています。 ログアウト / 変更 )

Twitter 画像

Twitter アカウントを使ってコメントしています。 ログアウト / 変更 )

Facebook の写真

Facebook アカウントを使ってコメントしています。 ログアウト / 変更 )

Google+ フォト

Google+ アカウントを使ってコメントしています。 ログアウト / 変更 )

%s と連携中